Drupal 5 больше не поддерживается официально

В шестой день рождения в Drupal, 15 января 2007 года был выпущен Drupal 5.0. И на протяжении последних четырех лет Нил Драмм (Neil Drumm) был в качестве главного майнтейнера этой версии вплоть до последнего коммита 6 января 2011 года.

Выпуск Drupal 7 означает, что Drupal 5 больше не поддерживается. Этот пост лишь напоминание об этом факте. Это такая политика в Drupal сообществе - поддерживать только текущую, основную версию Drupal (в настоящее время это Drupal 7.x), и предыдущую версию (в настоящее время это Drupal 6.x). Смотрите информацию о версии Drupal для более подробной информации об этой политике.

Drupal 5 больше не поддерживается официально.

Что это означает, что Drupal 5 больше не поддерживается официально?

  • Вы не должны ожидать, что какие-либо из этих вопросов будут зафиксированы в Drupal ядре.
  • Больше не будут закрываться дыры в безопасности как в ядре Drupal 5 так и в сторонних модулях.
  • Модуль обновления статуса, представленный с Drupal 5, опирается на XML с drupal.org. Это XML по-прежнему используется для новой версии модуля, но может быть изменен таким образом, что для Drupal 5 этот модуль перестанет работать.

Что это значит для вас?

Если вы несете ответственность за сайты, которые работают на Drupal 5.x, пришло время для обновления их до версии 6.x или 7.x. См. инструкции по обновлению и видео по переходу с Drupal 5 до Drupal 6. Обратите внимание, что 7.x еще относительно молодая версия, так что возможно не все еще можно будет перенести на нее.

Если вы сопровождаете модуль, тему или проект, то рекомендуется отметить, что версии 5.x больше не поддерживаются. Вы можете сделать это, перейдите в ваш проект, нажмите на вкладке Edit, затем - Releases и снемите флажки для "Supported" в строках для 5.x-релизов.

Вы можете подумать: "Эй, давайте поддерживать жизнь в Drupal 5!". И вы не одиноки. Существует Drupal Long Term Support группа, посвященная концепции, но до сих пор она имеет лишь ограниченный успех в этом вопросе.

Дополнительно Upgrading Drupal 5 to Drupal.