Плагин Drupal 6 для NetBeans 6.9.1 - 7 beta

Есть замечательный плагин Drupal 6.x (Drupal Module) для NetBeans. Единственный минус - он давно уже не обновлялся и не работает с версией NetBeans 6.9.1 и новой NetBeans 7 (которая на данный момент в beta версии).  Конечно уже версия Drupal 6 не совсем актуальна и пора переходить на Drupal 7. Но все равно этот плагин еще широко востребован среди друпал-разработчиков.

Так и я решил установить его. Скачал, но при установки получил сообщение об ошибке:

Для NetBeans 6.9.1:

The plugin Editor Library is requested in version >= 1.29.1.8.2 (release version 1)
but only 2.10.2.10.2 (of release version different from 1) was found.
The following plugin is affected:
Drupal Module

В русском варианте NetBeans 6.9.1:

Требуется плагин Библиотека Редактора (Editor Library) версии >= 1.29.1.8.2 (версия выпуска 1),
но был найден плагин версии 2.10.3.10.2 (с версией выпуска отличной от 1).
Затронут следующий плагин:
Drupal Module

Но я не остановился на этом. Нашел информацию, что теперь проект Drupal Module для NetBeans находиться по адресу java.net/projects/nbdrupalsupport. Скачал оттуда исходники плагина, открыл в NetBeans, затем в подключаемых библиотеках переподключил Editor Library новой версии 2.10.3.10.2. Пересобрал NBM файл, после чего плагин успешно установился и заработал.

Так же я пересобрал версию плагина и для NetBeans 7 beta.

Для тех, кому может пригодиться этот плагин, выкладываю его рабочую версию тут.

Ссылки на загрузку Drupal 6.x плагин (Drupal Module) для NetBeans 6.9.1 или для NetBeans 7 ниже:

Комментарии

Здравствуйте,
У меня проблема возникла, схожая с вашей. Получил следующую ошибку:

Требуется плагин Библиотека Редактора (Editor Library) версии >= 1.29.1.8.2 (версия выпуска 1),
но был найден плагин версии 2.10.3.10.2 (с версией выпуска отличной от 1).
Затронут следующий плагин:
Smarty Editor

Если не сложно, могли бы вы помочь с установкой Smarty Editor.
Какие действия мне следует предпринять?

Заранее спасибо за помощь.

Просто скачайте с этой страницы файл плагина 1.0.8 для NetBeans 6.9.1 и установите его. Должно все работать.

Скачал ваш вариант "Drupal 6.x плагин (Drupal Module) 1.0.8 для NetBeans 6.9.1" и у меня заработал теперь плугин для netbeans 6.9.1. :)
Спасибо!

Спасибо за сборку, похоже что я в который раз перейду с эклипса на нетбинс :)
Уже надоело менять IDEшки :(

Пожалуйста.
Скоро уже должна выйти стабильная версия NetBeans 7, по плану 4 апреля 2011 :)

Спасибо большое мил человек

А Drupal 6.x плагин (Drupal Module) 1.0.9 работает с NetBeans 7 beta 2, которая недавно вышла?

Да, работает.